Android Studio SDK Version 22

androidandroid-studio

Your Android SDK is out of date or is missing templates. Please ensure you are using SDK version 22 or later.

The machine I'm using I've not had Eclipse on before, but had to because of the SDK Issue,

I've installed

SDK 64bit here:

C:\Program Files\Java\jdk1.7.0_21

SDK 32bit here:

C:\Program Files (x86)\Java\jdk1.7.0_21

Android-Studio is install here:

C:\Program Files (x86)\Android\android-studio

Eclipse

C:\Program Files (x86)\Android\Eclipse

Now on another part of this forum a nice post said to change the settings in Configure -> Project Defaults -> Project Structures, but I'm not to sure what to change. I did go into project in (project settings), the list in there is:

  • None
  • 1.7 (java version 1.7.0_21)
  • Android SDK (java version 1.7.0_21)

I selected Android SDK (java version 1.7.0_21). Then there are the NEW and Edit buttons. But when I try to give it a path C:\Program Files\Java\jdk1.7.0_21 etc it says it's incompatible.

My environment variables are:

ANDROID_HOME = C:\Program Files (x86)\Java\jdk1.7.0_21
JAVA_HOME = C:\Program Files\Java\jdk1.7.0_21

Does anybody know how to fix this???

Best Solution

Also make sure that inside Configure > Projects Defaults > Projects Structure > Click on the "Android SDK" section at the bottom left panel and insert the path of your Android SDK like this: /Applications/Android Studio.app/sdk (Use the browser to point to the sdk folder).