Ios – CFBundleVersion Mismatch – The CFBundleVersion value does not match the CFBundleVersion value of its containing iOS application

imessage-extensionios

I'm new to the whole app world, and this is my first time using X-code (my apps I have built in the past, use Phonegap Build)

Anyway – I managed to create a stick page (eventually!). Now I've made some changes to it, but I can't for the life of me work out how to upload it! I get this error when pushing it:

CFBundleVersion Mismatch – The CFBundleVersion value '1' of extension
'Steampunk Junkies™ Sticker
Pack.app/PlugIns/StickerPackExtension.appex' does not match the
CFBundleVersion value '1.0.5.1' of its containing iOS application
'Steampunk Junkies™ Sticker Pack.app'.

CFBundleShortVersionString Mismatch – The CFBundleShortVersionString
value '1.0' of extension 'Steampunk Junkies™ Sticker
Pack.app/PlugIns/StickerPackExtension.appex' does not match the
CFBundleShortVersionString value '1.0.5' of its containing iOS
application 'Steampunk Junkies™ Sticker Pack.app'.

After you’ve corrected the issues, you can use Xcode or Application
Loader to upload a new binary to iTunes Connect.

My configs look like:

enter image description here

enter image description here

enter image description here

I've never had to manage the version numbers in X-Code before – so its entirly possible I've missed an important step when changing the version number.

Could someone please help me out? It's driving me up the wall!

NB: I'm using X-Code 8.2 beta (the version they offer you to download from the developer area)

UPDATE: Thank you so much to shallowThought helping me on this! While my setup didn't quite look like he posted, it made me look around to find the place he was talking about. In the end, I found it with the "down arrow", as circled below:

enter image description here

Once I clicked that, it let me view the information of the other section of the package. Man, I can't believe I missed that!

Best Solution

I consider it an App Store bug, caused by StickerPackExtension targets version and build version differs from the Steampunk Junkies™ Sticker Pack application targets version:

To fix the error simply copy the version to make sure they are the same for both targets.


Update:

If you can not see your targets, click this symbol: