.net – Windows 7 SDK for .NET 4.5

.net.net-4.5winapiwindows-7

I need to install the Windows 7 SDK.

I searched and found this page which says it is for .NET 4. (The system requirements indicate .NET 2-4)

I am using .NET 4.5. The only one for .NET 4.5 that I can see is for Windows 8.

Will the Windows 7 .NET 4 SDK work ok for my .NET 4.5 apps?

Best Solution

The SDKs contain tools to target specific .NET version and they are not "SDK X for .NET Y.Z" in terms that there are various flavors of the same SDK addressing different version of .NET. Instead it is just evolution of tools and most recent releases inside. That is, the choice is between:

You can have both installed side by side as well. Then you need to build your project targeting it for specific .NET version, you define this in your project settings.

You typically want the most recent SDK compatible with the version of Visual Studio you are using. You want SDK "... .NET 4.5" if you want to target .NET 4.5. Don't worry that it might possibly build apps limited to Windows 8 only, the description says directly:

You can use the SDK to build applications that target these operating systems: Windows 8, Windows 7, Windows Vista, Windows Server 2012, Windows Server 2008 R2, Windows Server 2008.