Objective-c – UUID mismatch detected with the loaded library

cocoa-touchiphoneobjective-c

I get a "UUID mismatch" warning at the console when I try to build and run my app on my iPhone.

warning: UUID mismatch detected with
the loaded library – on disk is:
/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS2.1.sdk/usr/lib/liblockdown.dylib
=uuid-mismatch-with-loaded-file,file="/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS2.1.sdk/usr/lib/liblockdown.dylib

Anyone has this issue and managed to resolve the warning ?

Best Solution

Uninstalling and reinstalling both the iOS on the device and the SDK did not fix this for me. The only way I was able to get around this issue was by deleting the DeviceSupport files for the 4.2.1 iOS version, which can be found at:

/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

After deleting the files and restarting Xcode, I plugged in my device and was prompted to restore the symbol files from the device itself - it took about 5 minutes and after this, everything was back to working perfectly.

Related Question