Php – Setting up Phppgadmin 5.0.2 with Xampp 1.7.4

phpphppgadminpostgresqlxampp

I was asked to perform(first time) a task in PHP with PostgreSQL for the purpose I intalled XAMPP 1.7.4, PostgreSQL 9.X, I was unaware how to setup phpPgadmin(5.0.2) so I googled and found Configuration Instruction here; and here

after configuring all this i found following error when i tried to https://localhost/phppgadmin

Your PHP installation does not support
PostgreSQL. You need to recompile PHP
using the –with-pgsql configure
option.

I googled again found some possible reasons those are

  1. you did't restarted aphace
  2. the php.ini you changed is not the right php.ini file, make it sure from xampp console under phpinfo()

I have checked both but still error is there no change at all. please someone help me, I already spent more than a business day, THANKs

Best Solution

As I replied there, copying around php/libpq.dll into apache/bin should (hopefully) do the trick.

Related Question