R – CRUD vs AGUD vs AFUD…what’s your naming convention of preference

actionscript-3crudnaming-conventions

Do you write createSomething() or addSomething()?

Do you write readSomething(), getSomething() or fetchSomething()?

This is totally a petty gripe. In the meeting room we refer to it as CRUD, but in actual code, it's becoming AGUD.

What's your naming convention of preference? Does it matter?

thnx.

Best Solution

I prefer CRUD over AGUD and AFUD.


CREATE Vs ADD

We are trying to use both of these words to indicate that we are building something new. CREATE leaves no room for interpretation; something that didnt exist before is now being built. ADD can be a little confusing because it could imply that we are adding something that already exists.


READ Vs. GET/FETCH

To me the problem with GET and FETCH here could be interprated as getting a sole instance of an object in order to modify it. I like using READ because it is clear in the sense that I want to read in an instance of an object and that modifying the modifying the object would require a seperate action.