Naming conventions: “State” versus “Status”


Quick question: I'd like to hear your thoughts on when to use "State" versus "Status" when naming both fields such as "Foo.currentState" vs "Foo.status" and types, like "enum FooState" vs "enum FooStatus". Is there a convention discussed out there? Should we only use one? If so which one, and if not, how should we choose?

Best Solution


status == how are you? [good/bad]

state == what are you doing? [resting/working]

Related Question