In data processing, I frequently need to create a lookup data structure to map one identifier to another. As a concrete example, let's take a structure which holds a 1-to-1 mapping between a country's 2 character code and its full name. In it we would have
AD -> Andorra
AE -> United Arab Emirates
AF -> Afghanistan
What's a good name for the variable that would hold this map? Some ideas (I'll use camel-case names):
countryNameByCode
nameByCodeLookup
nameCodeLookup
codeToName
Best Solution
My vote would be for
codeToName
in this particular case, and I guess that generalizes. That's not to say that it's the name I would have chosen myself in all cases; that depends a lot on scope, further encapsulation, and so on. But it feels like a good name, that should help make your code readable:Looks fairly nice, should be easily understandable by anyone. Possibly change the word "code" to something more precise ("countrycode" would be my next choice).